Thursday, 13 June 2013

CCNP ROUTE OSPF PART 1 : BASIC CONCEPTS OF OSPF

LAB ON YOUTUBE    http://youtu.be/0mVibaOw3zs

….for theoretical portion please refer to the you tube link at the end of this post….thanks for your cooperation.
Neighbour table
Topology table
Routing table
Neighbour Formation Process:
1. Router-id selection (higher interface or high loopback or with router-id commad)
2. Add interface with network command
3. DOWN STAT: start to send hello pkt to neighbour router
With 8 fields : route-id*|authentication & password*|Hello & Dead Timers*|Neighbours information|Netmask*|area-id*|router priority|DB/BDR
4.INIT STAT: neighbour router send * items in response
5.2WAY : neighbour table formation
6.Exchange/External STAT: database sync and Master/Slave
7.Loading : Depth of state 6 , 11LSA, LSU,LSR exchange, topology table formation.
8.FULL state : Routing table formed with SPF algorithm.
NOTE: ospf sends hello pkt after 10 sec in PtoP or broadcast network with is 30 sec in NBMA.
ospf1

The LSA types defined in OSPF are as follows:
·                     Type 1 - Router LSA – the router announces its presence and lists the links to other routers or networks in the same area, together with the metrics to them. Type 1 LSAs are flooded across their own area only. The link-state ID of the type 1 LSA is the originating router ID.
·                     Type 2 - Network LSA – the designated router (DR) on a broadcast segment (e.g. Ethernet) lists which routers are joined together by the segment. Type 2 LSAs are flooded across their own area only. The link-state ID of the type 2 LSA is the IP interface address of the DR.
·                     Type 3 - Summary LSA – an Area Border Router (ABR) takes information it has learned on one of its attached areas and summarizes it before sending it out on other areas it is connected to. This summarization helps provide scalability by removing detailed topology information for other areas, because their routing information is summarized into just an address prefix and metric. The summarization process can also be configured to remove a lot of detailed address prefixes and replace them with a single summary prefix, also helping scalability. The link-state ID is the destination network number for type 3 LSAs.
·                     Type 4 - ASBR-Summary LSA – this is needed because Type 5 External LSAs are flooded to all areas and the detailed next-hop information may not be available in those other areas. This is solved by an Area Border Router flooding the information for the router (i.e. the Autonomous System Boundary Router) where the type 5 originated. The link-state ID is the router ID of the described ASBR for type 4 LSAs.
·                     Type 5 - External LSA – these LSAs contain information imported into OSPF from other routing processes. They are flooded to all areas unchanged (except stub and NSSA areas). For “External Metric Type 1″ LSAs routing decisions are made using the Type 1 metric cost sent, as the total cost to get to the external destination and includes the cost to the ASBR; while for “External Type 2″ LSAs the metric sent is the cost from the ASBR to the External destination network and must be added to the OSPF cost to the ASBR advertising the Type 5. The link-state ID of the type 5 LSA is the external network number.
·                     Type 6 - Group Membership LSA(Only supported on a few routers) – this was defined for Multicast extensions to OSPF (MOSPF),[1] a multicast OSPF routing protocol which was not in general use. MOSPF has been deprecated since OSPFv3[2] and is not currently used. It may be reassigned in the future.
·                     Type 7 - Routers in a Not-so-stubby-area (NSSA) do not receive external LSAs from Area Border Routers, but are allowed to send external routing information for redistribution. They use type 7 LSAs to tell the ABRs about these external routes, which the Area Border Router then translates to type 5 external LSAs and floods as normal to the rest of the OSPF network.
·                     Type 8 - A link-local only LSA for OSPFv3. A Type 8 LSA is used to give information about link-local addresses and a list of IPv6 addresses on the link. In OSPFv2, however, the Type 8 was originally intended to be used as a so-called External-Attributes-LSA for transit autonomous systems where OSPFv2 could replace the internal Border Gateway Protocol (iBGP). In these networks, the BGP destinations would be carried in LSA Type 5 while their BGP attributes would be inserted into LSA Type 8. Most OSPFv2 implementations never supported this feature.
·                     Type 9 - a link-local “opaque” LSA (defined by RFC2370) in OSPFv2 and the Intra-Area-Prefix LSA in OSPFv3. It is the OSPFv3 LSA that contains prefixes for stub and transit networks in the link-state ID.
·                     Type 10 - an area-local “opaque” LSA as defined by RFC2370. Opaque LSAs contain information which should be flooded by other routers even if the router is not able to understand the extended information itself. Typically type 10 LSAs are used for traffic engineering extensions to OSPF, flooding extra information about links beyond just their metric, such as link bandwidth and color.
·                     Type 11 - an AS “opaque” LSA defined by RFC 5250, which is flooded everywhere except stub areas. This is the opaque equivalent of the type 5 external LSA.[3]
Note : above topic Taken for wiki:
OSPF METRIC VALUE:
ospf cost = 100/BW(Mbps)
56k = 1785
T1 = 65
E1 = 48
ethernet = 10
fastethernet = 1
>1Gbps = 1


CCNP ROUTE OSPF : LAB ON BASIC CONCEPTS
CCNP ROUTE OSPF LAB :


Ospf lab : lab one

TASK1:
configure all the routers with ospf ABR and ASBR redistribute rip into ospf with constant metric 55
TASK2:
make R1 DR for the ar 0 and R2 & R3 has only relation upto 2WAY, with R1 they have FULL relationship
TASK3:
do the summarization of ASBR and ABR
TASK4:
upgrade the link cost to Gigabit speed

==========================================================
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
ip address 172.16.1.1 255.255.255.255
!
interface Loopback3
ip address 172.16.1.2 255.255.255.255
!
interface Loopback4
ip address 172.16.1.3 255.255.255.255
!
interface Loopback5
ip address 172.16.1.4 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip ospf priority 30
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
summary-address 172.16.1.0 255.255.255.248
redistribute rip metric 55 subnets
network 1.1.1.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
!
router rip
version 2
network 172.16.0.0
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
End
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
ip ospf cost 1000
ip ospf priority 0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.24.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
area 10 range 4.4.4.0 255.255.255.248
network 2.2.2.2 0.0.0.0 area 0
network 10.1.24.0 0.0.0.3 area 10
network 192.168.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
End
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.3 255.255.255.0
ip ospf priority 0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.35.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.1.35.0 0.0.0.3 area 20
network 192.168.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
interface Loopback1
ip address 4.4.4.1 255.255.255.255
!
interface Loopback2
ip address 4.4.4.2 255.255.255.255
!
interface Loopback3
ip address 4.4.4.3 255.255.255.255
!
interface Loopback4
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.24.2 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 4.4.4.1 0.0.0.0 area 10
network 4.4.4.2 0.0.0.0 area 10
network 4.4.4.3 0.0.0.0 area 10
network 4.4.4.4 0.0.0.0 area 10
network 10.1.24.0 0.0.0.3 area 10
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
End
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
interface Loopback1
ip address 5.5.5.1 255.255.255.255
!
interface Loopback2
ip address 5.5.5.3 255.255.255.255
!
interface Loopback3
ip address 5.5.5.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.35.2 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 10.1.35.0 0.0.0.3 area 20
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

No comments:

Post a Comment